For *details on interpreting the data, click here

Performance Issues: Multiple Services Impact In US-EAST-1 Region

Incident Report for Pega Cloud

Resolved

Our teams have identified and resolved an issue affecting new EC2 instance launches in the Northern Virginia region. Services are now stable and available for all users.
Posted Sep 22, 2026 - 00:49 UTC

Identified

We have identified elevated error rates impacting new EC2 instance launches in the Northern Virginia region. Our engineers are actively engaged and working towards recovering. Performance issues may be encountered.
Posted Sep 22, 2026 - 00:21 UTC
This incident affected: Pega Infinity Americas (AWS: USA - Northern Virginia).