For *details on interpreting the data, click here

GenAI and Blueprint performance degradation

Incident Report for Pega Cloud

Resolved

Our teams have identified and resolved the global issue affecting GenAI and Blueprint utilizing the Azure models. GenAI and Blueprint are now stable and available for all users.
Posted May 29, 2026 - 13:25 UTC

Update

We are continuing to monitor for any further issues.
Posted May 29, 2026 - 13:10 UTC

Monitoring

We're seeing services begin to recover. We will continue to monitor the issue and report back with a final update shortly.
Posted May 29, 2026 - 13:08 UTC

Investigating

We are currently experiencing degraded performance issue with GenAI and Blueprint services that is impacting multiple clients globally The impact on your experience may vary based on your platform or application. We apologize for any inconvenience and appreciate your patience while we work to resolve the issue.
Posted May 29, 2026 - 12:44 UTC
This incident affected: Pega GenAI (Pega GenAI Blueprint, Pega GenAI).