For *details on interpreting the data, click here

AWS Direct Connect Service Disruption

Incident Report for Pega Cloud

Identified

We have identified the issue affecting AWS Direct Connect in Europe (Frankfurt), specifically impacting the Equinix service provider, which may affect multiple clients. Our team is actively working to restore service. We apologize for the inconvenience. Updates will be provided here when available.
Posted Aug 17, 2026 - 06:20 UTC

Investigating

We are currently experiencing AWS Direct Connect issue in Europe (Frankfurt) specifically for Equinix service provider that may affect multiple clients. Clients might face issues while login into the environment. We apologize for any inconvenience and appreciate your patience while we work to resolve the issue.
Posted Aug 17, 2026 - 05:11 UTC
This incident affects: Pega Infinity EMEA (AWS: Germany - Frankfurt).